HSRP (+VLANs) | GNS3 | NETWORKING

  • HSRP= Hot Stand-by Redundancy Protocol. HSRP envía paquetes "hello" vía la dirección multicast 224.0.0.2 y por defecto los envía cada 3 segundos y el tiempo por defecto para declarar un router inaccesible son 10 segundos, ambos tiempos pueden ser ajustados hasta milisegundos para obtener un mejor rendimiento en el failover. Si el router que se encuentra en modo Standby deja de recibir mensajes "hello" desde el router activo, entonces éste asume el control de la topología. 
  • HSRP requiere conectividad de capa 2 (Layer 2) entre los routers. Estados HSRP (HSRP consta de 5 estados de operación):
    • Initial: Aquí aún NO está trabajando HSRP, éste estado es cuando la interfase acaba de subir.
    • Listen: Escucha los "Hellos", conoce la IP virtual.
    • Speak: Envía Hellos Messages y participa en la elección de los routers (Active/Passive)
    • Standby: Es candidato para el próximo active router.
    • Active: Es el encargado de enviar paquetes hacia la IP virtual.
http://blog.capacityacademy.com/2013/01/07/cisco-ccnp-que-es-y-como-configurar-el-protocolo-hsrp/
https://echaleunvistazo.wordpress.com/2015/02/13/protocolos-de-redundancia-hsrp/
  • La principal característica del HSRP es la posibilidad de asignar direcciones IP virtuales a cada grupo. Si el router primario deja de funcionar, el secundario ocupará su lugar, mientras que la dirección IP virtual seguirá siendo la misma.
  • No Switchport= Comando que permite poner una interfaz en un switch de capa 3, en dicha capa (la 3 pu wea), ya que un switch trabaja como capa 2 y para poder asignar algo como una dirección IP se necesita de cambiar este modo en que trabaja (de capa 2 a capa 3, o modo "puerto router").
  • La diferencia entre los comandos "no ip routing" y "no switchport" es que uno afecta a todas las interfaces y el otro va dirigido a la interfaz en la cual se aplica.

Descargar programa y recursos utilizados: AQUÍ

Partiremos por el switch SW3 a modo de asegurar la conexión entre SW1 y SW2:
SW3(config)#int g0/1
SW3(config-if)#switchport trunk encapsulation dot1q 
SW3(config-if)#switchport mode trunk 
SW3(config-if)#no shut         *Abreviado de= no shutdown

SW3(config)#int g0/0
SW3(config-if)#switchport trunk encapsulation dot1q 
SW3(config-if)#switchport mode trunk 
SW3(config-if)#no shut

SW3(config)#int g0/2
SW3(config-if)#switchport mode access 
SW3(config-if)#switchport access vlan 10
 % Access VLAN does not exist. Creating vlan 10
SW3(config-if)#no shut

SW3(config)#int g0/3        [con R2 nos saldran mensages de "no half duplex" si se deja que exista el conflicto de velocidades, ya que vemos que conecta con una interfaz GigabitEthernet, por lo que se descartarian paquetes dando problemas]
SW3(config-if)#no negotiation auto    [para solucionar estas alertas cambiamos el modo en que opera esta interfaz, quitamos que la negociacion de paquetes sea automatica]
SW3(config-if)#duplex full          [y asignamos que pueda hacer uso total del enlace mediante full duplex]
SW3(config-if)#switchport mode access 
SW3(config-if)#switchport access vlan 20
 % Access VLAN does not exist. Creating vlan 20
SW3(config-if)#no shut

Seguimos por el Switch que queremos dejar como Activo, en este caso es SW1:
SW1(config)#vlan 10      [crea la vlan 10]
SW1(config-vlan)#vlan 20    [crea la vlan 20, puede ser creada dentro de la configuracion que abre el comando anterior o por separado como se hizo con la vlan 10 (desde "conf t")]

SW1(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10       [excluimos las primeras 10 direcciones para difenreciarlo del Switch SW2 (Standby)]
SW1(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.10

SW1(config)#ip dhcp pool vlan_10
SW1(dhcp-config)#network 10.0.0.0 
SW1(dhcp-config)#default-router 10.0.0.100    [acá asignamos la IP virtual]

SW1(config)#ip dhcp pool vlan_20
SW1(dhcp-config)#network 192.168.0.0
SW1(dhcp-config)#default-router 192.168.0.100  [igualmente en el otro pool la IP virtual en el router por defecto]

SW1(config)#int g0/0
SW1(config-if)#no switchport     [habilitamos que permita enrutado solamente para poder transmitir IP]
SW1(config-if)#no shut

SW1(config-if)#int g0/0.10
SW1(config-subif)#encapsulation dot1Q 10    [habilitamos encapsulación para poder transmitir VLAN's, el número 10 es el número de la VLAN que queremos que trabaje en esta sub-interfaz]
SW1(config-subif)#ip add 10.0.0.1 255.255.255.0
SW1(config-subif)#standby 1 ip 10.0.0.100     [IP virtual de HSRP]
SW1(config-subif)#standby 1 priority 120      [le aumentamos la prioridad por defecto (100) para que quede como principal/activo]
SW1(config-subif)#standby 1 preempt        [con preempt le informamos que regrese a tomar el puesto de activo tras regresar de alguna caida]
SW1(config-subif)#no shut 
 %HSRP-5-STATECHANGE: GigabitEthernet0/0.10 Grp 1 state Standby -> Active

SW1(config)#int g0/0.20
SW1(config-subif)#encapsulation dot1Q 20
SW1(config-subif)#ip add 192.168.0.1 255.255.255.0
SW1(config-subif)#standby 2 ip 192.168.0.100     [IMPORTANTE cambiar el número de grupo, en este caso utilizamos el grupo 2 para la VLAN 20 ya que el grupo 1 pertenece a la VLAN 10]
SW1(config-subif)#standby 2 priority 120
SW1(config-subif)#standby 2 preempt 
SW1(config-subif)#no shut
 %HSRP-5-STATECHANGE: GigabitEthernet0/0.20 Grp 2 state Standby -> Active

Pasamos al que quedara en modo espera (Standby) SW2:
SW2(config)#vlan 10 
SW2(config-vlan)#vlan 20 
 
SW2(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.20   [ahora exluimos hasta 20 direcciones]
SW2(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.20
 
SW2(config)#ip dhcp pool vlan_10
SW2(dhcp-config)#network 10.0.0.0
SW2(dhcp-config)#default-router 10.0.0.100

SW2(config)#ip dhcp pool vlan_20
SW2(dhcp-config)#network 192.168.0.0
SW2(dhcp-config)#default-router 192.168.0.100

SW2(config)#int g0/1
SW2(config-if)#no switchport
SW2(config-if)#no shut

SW2(config)#int g0/1.10           [fijarse en el cambio de interfaz aca ya no es la cero]
SW2(config-subif)#encapsulation dot1q 10
SW2(config-subif)#ip add 10.0.0.2 255.255.255.0
SW2(config-subif)#standby 1 ip 10.0.0.100          [en este caso dejaremos los parametros entorno a la prioridad por defecto ya que son menores a los establecidos en el SW1, lo que deja a este Switch como Standby]
SW2(config-subif)#no shut
 %HSRP-5-STATECHANGE: GigabitEthernet0/1.10 Grp 1 state Speak -> Standby

SW2(config)#int g0/1.20
SW2(config-subif)#encapsulation dot1q 20
SW2(config-subif)#ip add 192.168.0.2 255.255.255.0
SW2(config-subif)#standby 2 ip 192.168.0.100
SW2(config-subif)#no shut
        %HSRP-5-STATECHANGE: GigabitEthernet0/1.20 Grp 2 state Speak -> Standby

Terminamos con los Router-PC R1:
R2(config)#no ip routing      [para que opere como dispositivo final (PC)]
 
R2(config)#int g1/0
R2(config-if)#ip add dhcp
R2(config-if)#no shut

Y el Router-PC R2:
R2(config)#no ip routing
 
R2(config)#int g1/0
R2(config-if)#ip add dhcp
R2(config-if)#no shut

Comprobamos configuraciones HSRP:
Desde ambos switch vIOS-L2 debería ser:
SW?#show standby
*Deberían dar algo así=

Comprobamos estado HSRP:
Desde ambos switch vIOS-L2 debería ser:
SW?#show standby brief
*Deberían dar algo así=

Comprobamos estado DHCP+VLANs:
Desde ambos Router-PC debería ser:
R?#show dhcp lease
*Deberían dar algo así=


AHORA APAGAREMOS LA INTERFAZ G0/0 PERTENECIENTE AL SWITCH SW1 A MODO DE QUE SW2 CAMBIE DE MODO "EN ESPERA" A "ACTIVO"

SW1:
SW1(config)#int g0/0
SW1(config-if)#shutdown   [para apagar la interfaz]
  %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 1 state Active -> Init   [esperaremos a que se nos muestre este mensaje para continuar, el cual informa que a cambio de activo a init (inactivo o initial a mi me gusta decirle inactivo)]

SW2: (fijarse que igualmente cambie el estado de forma automática en el otro switch)
  %HSRP-5-STATECHANGE: GigabitEthernet0/1.10 Grp 1 state Standby -> Active
  %HSRP-5-STATECHANGE: GigabitEthernet0/1.20 Grp 2 state Standby -> Active 

Comprobamos nuevamente configuraciones HSRP:
Desde ambos switch vIOS-L2 debería ser:
SW?#show standby
*Deberían dar algo así=

Comprobamos nuevamente estado HSRP:
Desde ambos switch vIOS-L2 debería ser:
SW?#show standby brief
*Deberían dar algo así=

Comprobamos otra vez estado DHCP+VLANs:
Desde ambos Router-PC debería ser (recordar pedir DHCP nuevamente igual antes):
R?#show dhcp lease
*Deberían dar algo así=

Comando adicionales vistos en esta configuración:
-IP ADD
-HOSTNAME
-NO IP ROUTING
-DHCP
-VLAN's
-HSRP (Sin: Track, Prioridad y Autenticación)
 

MÁS COMANDOS AQUÍ

 

Comentarios

  1. Casino Site | Best Casino Sites in Indonesia
    Our Casino Site งานออนไลน์ review to find out everything you need to know 카지노사이트 about the casino site and its features. Learn about their 온카지노 bonuses, games, payment methods,

    ResponderBorrar

Publicar un comentario